TrainController – Altlasten „Steuerwagen“

Ich nutze TC (TrainController) bereits seit vielen Jahren. Mein aktuelles Projekt (meine Anlage) habe ich mit erscheinen der Version 5.5 neu erstellt. Seit dem wurde das Projekt einmal nach meinen Bedürfnissen aber auch aufgrund neuer Funktionen ständig erweitert. Das bezieht sich sowohl auf die Darstellung des Stellwerkes als auch auf die eingepflegten Fahrzeuge.

Gab es in früheren Versionen nur sie Unterscheidung „Lok“ und „Wagen“, kam später unter „Wagen“ noch der Haken „Steuerwagen“ dazu.
Deshalb waren die meisten meiner Steuerwagen als „Lok“ definiert, denn nur dadurch war es möglich, den Lichtwechsel weiß/rot in einem Zugverband anzusteuern.

Und wie es so ist, solange die Züge laufen, kümmert man sich nicht um die Altlasten.

Nun habe ich vor einigen Wochen meine „modus“ Garnitur mit Beleuchtung und stromführenden Kupplungen ausgerüstet. Die 3-teilige Garnitur (2 Wagen + 1 Steuerwagen) wurden an eine ÖBB Rh 1014 gehängt. Irgendwie lief es aber nicht sauber.
Deshalb wurde erst Mal die Lok so lange auf Einmessstrecke und Programmiergleis gestellt, bis sie den eigenen Wünschen gerecht wurde.

Seltsanerweise machte die Lok mit dem Zug immer einen Sprung beim Anfahren auf eine recht hohe Decoderstufe, obwohl die Kriechgeschwindigkeit neu justiert auf Stufe 2 steht.

Im Zugverband werkeln bekanntlich mindestens 2 Einheiten, also den Steuerwagen vorgenommen, und siehe da, der war noch als Lok definiert. In Version 9 kann ein Steuerwagen jetzt mit genau diesem Attrib versehen werden, damit alle Lokfunktionen wie Licht usw. sauber angesteuert werden, ohne die Eigenschaften der Zuglok zu verändern.
Das habe ich jetzt angepasst, neuen Wagen angelegt, die Parameter übertragen (z.B. Länge und Lokfunktionen) und den alten gelöscht.

Jetzt startet der Zugverband schön langsam ab Kriechgeschwindigkeit 🙂

Hier noch ein Foto vom Steuerwagen „solo“ inkl. Beleuchtung

Steuerwagen „modus“ – Nahverkehr